Tablets & Modems

Support:
Reply
Occasional Visitor
icecool
Posts: 1
Registered: ‎2012-11-07
0

Modems K3805-z (ZTE) Modem will not ENABLE

Hello.

 

I got the k3805-z modem about 9 months ago and it worked fine on my win7 x64 pc until a few days ago. Whenever I plug the device into the usb port, it loads fine, autoruns and is detected in VMB. The problem is that after detection, the connection notification says 'enabling device' and stops there.

 

I have tried ticking the Enabled box but does not want to enable. (Where can we force Enable?)

 

I have tried the following:

Downloading Setup-10.2.302.33178RP196,zip (DISK1)

Manually uninstalled and reinstalled all device related to the modem in Control Panel

Deleted all drivers related to the modem off of the harddrive before doing a fresh install

Using different usb ports - did not work (restarted every time.)

 

The symptoms are:

 

The device will flash red until it is picked up by the operating system and then stop blinking (no light flashing). VMB will then show 'enabling device' and stop there.

 

My conclusion is that:

 

VMB adds an entry into the registry that tells the operating system to disable the device and somewhere the instructions went bonkers and will no longer enable.

 

If this is a wrong conclusion, please let me know and help me with a solution. If the conclusion is right, please let me know where in the registry VMB adds the entry and how I can manually change it. If the enable/disable instruction is located elsewhere, please let me know where I can check.

 

thanks.